Gut Zoomer 4.0 report maybe unable to view

Incident Report for Status Page

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 12:41 PDT

Identified

For orders that contain Gut zoomer 4.0, users may not be able to view the reports. We have noted the sense of urgency and are looking into this.
Posted Aug 21, 2025 - 11:15 PDT
This incident affected: Additional Service (Test Report PDF).